热搜: 股票怎么玩  股票入门基础知识  股市在线查询  股票大盘分析  股票行情 
 
当前位置: 首页 » 股票知识 » 股票怎么玩 » 正文

同花顺MACD止跌选股指标公式

放大字体  缩小字体 发布日期:2021-03-05  浏览次数:5

DIF3:=EMA(CLOSE,9)-EMA(CLOSE,17);
DEA3:=EMA(DIF3,8);
MACD3 := 2*(DIF3-DEA3);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
止跌:MACD3>REF(MACD3,1) AND REF(MACD3,2)>=REF(MACD3,1)AND J<50 ANDC>REF(C,1) AND C>O AND J>REF(J,1);
DIFF:EMA(DCLOSE,12)-EMA(DCLOSE,26);
// 1.蓝线B:鳄鱼的颚。取 13根bar的平滑移动平均将结果往未来的方向移动8根bar得到。
RGB_B : REF(SMA(CLOSE, 13, 1), 8), colorblue;
// 2.红线R:鳄鱼的牙齿。取8根bar的平滑移动平均将结果往未来的方向移动5根bar得到。
RGB_R : REF(SMA(CLOSE, 8, 1), 5), colorred;
// 3.绿线G:鳄鱼的上唇。取5根bar平滑移动平均数将结果往未来的方向移动3根bar得到。
RGB_G : REF(SMA(CLOSE, 5, 1), 3), colorgreen;
// A.经典碎形:5根bar组成中间的高点一定最高左右各两根线有较低高点。分辨向上碎形时只关注高点位置。
// B.向上与向下碎形共享外围bar
// C.向上、向下碎形由一根bar完成
// D.如今天高点与之前高点相同今天的bar不算在5根bar之内
DRAWTEXT(REF(HHV(HIGH, 5), 1) = REF(HIGH, 3), REF(HIGH, 3), '◤');
DRAWTEXT(REF(LLV(LOW, 5), 1) = REF(LOW, 3), REF(LOW, 3), '◤');
// 1.AO市场最好的动量指标。测量最近5个价格bar的动能并与过去34个bar作比较。等于过去5个bar的 最高点+最低点/2取移动平均-过去34个bar的 最高点-最低点/2取移动平均。
TP01 = ( HIGH + LOW ) / 2;
AO := SMA(TP01, 5, 1) - SMA(TP01, 34, 1);
// 2.AC领先动能的指标。AO与其5日简单移动平均的差值再做5日简单移动平均。
AC := SMA(AO - SMA(AO, 5, 1), 5, 1);
IF ( AO > REF(AO, 1) AND AC > REF(AC, 1) ) THEN
// 1.绿色区域:强劲的多头市场。加仓条件是AO上行AC上行价格收盘于更高位置
DRAWGBK(1, STRIP(RGB(153,204,51),RGB(150,180,100),0));
ELSE IF ( AO < REF(AO, 1) AND AC < REF(AC, 1) ) THEN
// 2.红色区域:强劲的空头市场。清仓。 原加仓条件AO下行AC下行价格收盘于更低位置。
DRAWGBK(1, STRIP(RGB(255,153,102),RGB(255,153,102),0));
ELSE
// 3.灰色区域:过渡期。不操作。
DRAWGBK(1, STRIP(RGB(99,99,99),RGB(99,99,99),0));


 
关键词: 通达信公式
 
[ 股票知识搜索 ]  [ 加入收藏 ]  [ 告诉好友 ]  [ 打印本文 ]  [ 违规举报 ]  [ 关闭窗口 ]

 
 
推荐股票知识
点击排行