当前位置: 首页 » 股票知识 » 股票入门基础知识 » 正文

飞狐江恩百分比主图指标公式

放大字体  缩小字体 发布日期:2020-11-16  浏览次数:22

input:w(2,1,3);
u1:=sysparam(3);
u:=u1-sysparam(2)+1;
hh:=hhv(H,u);
ll:=llv(L,u);
最高:=hh[u1],COLORYELLOW;
PARTLINE(C and w<>3,最高),COLORYELLOW;
最低:ll[u1],COLORred;
PARTLINE(C and w<>3,最低),COLORred;
PARTLINE(C and w=1,最低+(最高-最低)*0.191),LINEDOT,COLORWHITE;
PARTLINE(C and w=1,最低+(最高-最低)*0.382),LINEDOT,COLORWHITE;
PARTLINE(C and w<>3,最低+(最高-最低)*0.5),COLORGREEN;
PARTLINE(C and w=1,最低+(最高-最低)*0.618),LINEDOT,COLORWHITE;
PARTLINE(C and w=1,最低+(最高-最低)*0.809),LINEDOT,COLORWHITE;
DRAWTEXT(BARSCOUNT(C)=SYSPARAM(3) and w<>3,REF(最低,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'最低↓'),ALIGN2,COLORred;
DRAWTEXT(BARSCOUNT(C)=SYSPARAM(3) and w<>3,REF(最高,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'最高↑'),ALIGN2,COLORYELLOW;
DRAWTEXT(BARPOS=SYSPARAM(2) and w=1,REF((最低+(最高-最低)*0.191)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'黄金 0.191↑'+NUMTOSTR(最低+(最高-最低)*0.191,2)),COLORWHITE;
DRAWTEXT(BARPOS=SYSPARAM(2) and w=1,REF((最低+(最高-最低)*0.382)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'黄金 0.382↑'+NUMTOSTR(最低+(最高-最低)*0.382,2)),COLORWHITE;
DRAWTEXT(BARPOS=SYSPARAM(2) and w<>3,REF((最低+(最高-最低)*0.5)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM (2))),' 50% ↑'+NUMTOSTR(最低+(最高-最低)*0.5,2)),COLORGREEN;
DRAWTEXT(BARPOS=SYSPARAM(2) and w=1,REF((最低+(最高-最低)*0.618)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'黄金 0.618↑'+NUMTOSTR(最低+(最高-最低)*0.618,2)),COLORWHITE;
DRAWTEXT(BARPOS=SYSPARAM(2) and w=1,REF((最低+(最高-最低)*0.809)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'黄金 0.809↑'+NUMTOSTR(最低+(最高-最低)*0.809,2)),COLORWHITE;
{ Gupang.com 股-旁-网_飞狐股票指标公式}
PARTLINE(C and w=2,最低+(最高-最低)*1/8),LINEDOT,Color0095BC;
PARTLINE(C and w=2,最低+(最高-最低)*1/4),LINEDOT,Color0095BC;
PARTLINE(C and w=2,最低+(最高-最低)*3/8),LINEDOT,Color0095BC;
PARTLINE(C and w=2,最低+(最高-最低)*5/8),LINEDOT,Color0095BC;
PARTLINE(C and w=2,最低+(最高-最低)*7/8),LINEDOT,Color0095BC;
PARTLINE(C and w=2,最低+(最高-最低)*3/4),LINEDOT,Color0095BC;
DRAWTEXT(BARPOS=SYSPARAM(2) and w=2,REF((最低+(最高-最低)*1/8)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'江恩 1/8↑'+NUMTOSTR(最低+(最高-最低)*1/8,2)),Color0095BC;
DRAWTEXT(BARPOS=SYSPARAM(2) and w=2,REF((最低+(最高-最低)*1/4)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'江恩 1/4↑'+NUMTOSTR(最低+(最高-最低)*1/4,2)),Color0095BC;
DRAWTEXT(BARPOS=SYSPARAM(2) and w=2,REF((最低+(最高-最低)*3/8)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'江恩 3/8↑'+NUMTOSTR(最低+(最高-最低)*3/8,2)),Color0095BC;
DRAWTEXT(BARPOS=SYSPARAM(2) and w=2,REF((最低+(最高-最低)*5/8)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'江恩 5/8↑'+NUMTOSTR(最低+(最高-最低)*5/8,2)),Color0095BC;
DRAWTEXT(BARPOS=SYSPARAM(2) and w=2,REF((最低+(最高-最低)*7/8)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'江恩 7/8↑'+NUMTOSTR(最低+(最高-最低)*7/8,2)),Color0095BC;
DRAWTEXT(BARPOS=SYSPARAM(2) and w=2,REF((最低+(最高-最低)*3/4)*0.996,BARSLAST(BARSCOUNT(C)=SYSPARAM(2))),'江恩 3/4↑'+NUMTOSTR(最低+(最高-最低)*3/4,2)),Color0095BC;


 
关键词: 飞狐公式
 
[ 股票知识搜索 ]  [ 加入收藏 ]  [ 告诉好友 ]  [ 打印本文 ]  [ 违规举报 ]  [ 关闭窗口 ]

 

 
推荐股票知识
点击排行